뽐뿌

개발자포럼 입니다.

북마크 아이콘

IT 개발자간 정보를 공유하고 논의가 이루어지는 공간입니다.
[번역] OSX에서 php5.6과 php7을 동시에 설치해서 사용하는 방법(Homebrew, PHP-FPM 사용) 2
분류: TIP
이름: 카마파쵸


등록일: 2017-03-13 12:46
조회수: 1244 / 추천수: 3







기존에 PHP5 기반이던 플랫폼을 PHP7로 마이그레이션 하면서 한 서버에서 두개 버전을 동시에 사용할 수 있는 방법이 없을까 고민하다가 찾은 문서입니다. 비슷한 고민을 하시는 분들 계시면 도움될까 해서 다른곳에 올렸던 번역본을 한번 올려봅니다.


OSX기반으로 설명해 놓은 자료이기는 하나, 설치와 관련된 homebrew를 제외하면 대략 비슷한 과정이므로 별로 어렵진 않을거예요 (윈도우쪽은 잘 모르겠음) 


* 마이그레이션 작업자체는 단순노가다성 작업이 많았습니다.


  저는 vi 에디터를 쓰는데, 패턴을 활용해서 bulk find/replace 기능을 이용하니 대략 500여개 파일을 2~3시간정도면 작업을 할 수 있더군요. 


영어원문: https://www.symfony.fi/page/how-to-run-both-php-5-6-and-php-7-x-with-homebrew-on-os-x-with-php-fpm


==============================================================


PHP는 7.x 대 버전에서 마지막 PHP 5 버전 인 5.6보다 훨씬 개선되었습니다. 그러나 아직 다른 프로그램들 다수가 7.X를 지원하지 않는 경우가 많아 로컬 환경에서 많은 버전을 실행하는 것이 유용하다고 생각됩니다. 필자의 경우 macOS 노트북에서 Homebrew 패킷 관리자를 사용하는 환경이므로 이걸 기준으로 PHP 5.6과 PHP 7.1을 동시에 실행하는 방법을 설명하겠습니다.


 PHP 7.0은 웹의 많은 부분을 차지하는 인기있는 프로그래밍 언어/플랫폼의 큰 변경이었습니다. 새로운 PHP 릴리즈는 성능 향상새로운 기능을 제공합니다. PHP 커뮤니티는 릴리즈가 이전 버전과 호환되는지 확인하기 위해 많은 노력을 기울이고 있습니다. 대부분 호환가능 하지만, 일부 호환되지 않는 부분이 공식 마이그레이션 가이드에 설명되어 있습니다.


 eZ Publish 5는 최신 PHP뿐만 아니라 2003 년으로 거슬러 올라가는 구형 코드와의 하이브리드 응용 프로그램입니다. 이 버전은 완전히 새로운 아키텍처에 이르는 중간 단계였습니다. 2014 년에 eZ Platform이라는 신제품에 집중하면서 eZ Publish에 대한 새로운 기능 개발은 중단되었습니다.


새로운 기능을받지 못함에도 불구하고 eZ Publish는 여전히 유효한 제품이며 2021 년까지 계속 지원 될 것입니다. 마지막 주 버전은 PHP 7이 출시되기 전에 출시된 까닭에 결코 공식적인 지원을받지 못할 것으로 보입니다. 새로운 Symfony Framework로 구동되는 eZ Platform은 이미 개발용으로 PHP7에서 안정적입니다.


eZ 제품뿐만 아니라 PHP로 작업하는 많은 개발자들이 앞으로 여러 버전의 런타임을 유지해야 할 필요가 있다고 보여집니다.


  


Homebrew로 두 가지 버전의 PHP 설치하기


OS X (El Capitan)에서 PHP로 작업하는 개발자는 PHP 를 설치하기 위한 방법으로 내장된 PHP를 활성화시키는 것부터 LAMP 환경을위한 전용 가상 머신을 실행하는 것에 이르기까지 여러가지 다양한 방법이 가능합니다. 좋은 방법 중 하나는 Homebrew 패킷 관리자를 사용하는 것입니다.


 Homebrew는 많은 Linux 사용자에게 익숙한 APT 혹은 Yum과 매우 비슷하지만 OS X용 패키지관리자입니다. Homebrew가 아직 설치되어 있지 않은 경우 홈페이지 나 설치 안내서를 참고하세요. OS X에서 PHP를 실행하는 다른 방법대비 추가 이점으로, brew를 사용하면 php-imagick, php-intl, php-xsl  등등  eZ 실행에 필요한 PHP 익스텐션을  쉽게 설치할 수 있습니다.


Brew에는 저장소에 여러 가지 버전의 PHP가 있습니다. 패키지 이름에 숫자를 붙여서 관리됩니다. (예 : PHP 5.6의 경우 php56, PHP 7.0의 경우 php70). PHP의 "dot 릴리스"는 새로운 기능을 제공해서 하위 호환성이 깨질 수 있기 때문에 향후는 PHP 7.1 용 패키지 는 php71 이 제공 될 예정입니다.


 패킷 관리자를 설치했다면 이제는 PHP를 설치할 차례입니다. PHP 5.6 부터 설치하겠습니다..



brew install php56

이 작업을 실행하는 데는 시간이 걸리겠지만 최신버전의 PHP 56이 설치됩니다. 설치가 끝나면 php --version 명령을 실행하여 PHP 56이 설치되었는지 확인할 수 있습니다 : 



janit @ turska ~ - $ php --version
PHP 5.6.18 (cli) (빌드 : Feb 6 2016 06:53:53)
Copyright (c) 1997-2016 The PHP Group
Zend Engine v2.6.0, Copyright (c) 1998-2016 Zend Technologies

그러나이 여기서는 PHP 7.0을 기본 버전으로 만들 것이므로 PHP 파일에 대한 심볼릭 링크를 제거하는 명령을 실행해야합니다. 



janit @ turska ~ - $ brew unlink php56
Unlinking /usr/local/Cellar/php56/5.6.18 ... 18 symlinks removed

이제 php56을 가리키는 파일 시스템 링크가 제거되었습니다. 이제 PHP 7.0을 설치하겠습니다.



brew install php70

작업이 완료되면 기본 버전이 PHP 7인지 확인하십시오:




PHP 7.0.4 (cli) (built: Mar  9 2016 12:26:14) ( NTS )


Copyright (c) 1997-2016 The PHP Group


Zend Engine v3.0.0, Copyright (c) 1998-2016 Zend Technologies


    with Zend OPcache v7.0.6-dev, Copyright (c) 1999-2016, by Zend Technologies



커맨드라인에서 에서 PHP 5.6을 쉽게 실행할 수있도록 symlink를 생성하겠습니다: (현재시점 최신버전 5.6.29_5 버전 기준)



 ln -s /usr/local/Cellar/php56/5.6.29_5/bin/php /usr/local/bin/php56

이 작업이 끝나면 터미널에서 php56 명령으로 PHP 5.6을 사용할 수 있습니다.


  


PHP-FPM을 사용하여 여러 PHP 버전 설정하기


PHP는 웹 애플리케이션을 구동하는 데 가장 많이 사용되므로 두 개의 PHP 엔진을 각각의 버전에 연결해야합니다. PHP-FPM은 프로세스 관리자와 FastCGI 프로토콜을 사용하여 PHP를 실행하는 현대적인 방법입니다. PHP-FPM으로 다양한 버전의 PHP를 쉽게 전환 할 수있을뿐만 아니라 고성능을 가능하게합니다.


 아파치 웹 서버에서도 PHP-FPM을 사용할 수 있지만 여기서는 Nginx 웹 서버를 사용하겠습니다. Homebrew로 Nginx를 설치하려면 다음 지시 사항을 따르십시오. 지시사항에는 Nginx 및 PHP-FPM을 OS X에서 설치하고 실행하는 데 필요한 모든 것이 포함되어 있습니다.


 기본적으로 PHP-FPM은 통신을 위해 포트를 사용하도록 구성됩니다. IP 주소와 포트는 함께 하나의 IP로 여러개의 백엔드를 실행할 수있는 소켓을 형성합니다. PHP-FPM의 경우 사용 된 기본 소켓은 가상 호스트 설정 (/usr/local/etc/nginx/servers/ 에 위치)에 다음과 같이 표시되어 있습니다 :



fastcgi_pass 127.0.0.1:9000;

이 명령어의 의미는, Nginx로 들어오는 FastCGI 요청은 IP 127.0.0.1 의 포트 9000을 수신하고 있는 PHP 프로세스 관리자에게 전달됩니다. 포트 9000은 단지 기본값이며 구성을 변경하여 수정할 수 있습니다. 우리는 PHP 7.0을 기본 포트에서 수신하도록 두고 5.6버전은 포트 9056을 수신하도록 설정하겠습니다.


텍스트 편집기에서  /usr/local/etc/php/5.6/fpm.d/www.conf 를 엽니다:



listen = 127.0.0.1:9056

두개의 포트 (9000 및 9056)에서 수신 대기하도록 구성된 두 개의 PHP-FPM이 있지만 현재까지는 실행하고 있지 않습니다. 시스템을 재시작할때 둘 다 자동으로 시작할 수 있도록 하려면 약간의 작업이 필요합니다. 이것은 표준 Homebrew 방식을 사용하여 수행됩니다.


시작 에이전트 용 디렉토리를 만듭니다 (이미 존재할 수도 있음).



mkdir -p ~ /Library/LaunchAgents

시작 스크립트를 LaunchAgents 디렉토리에 복사하십시오.




cp /usr/local/opt/php70/homebrew.mxcl.php70.plist ~ /Library/LaunchAgents/


cp /usr/local/opt/php56/homebrew.mxcl.php56.plist ~ /Library/LaunchAgents/



마지막으로 두 PHP-FPM 프로세스를 시작합니다 - 이번에만 수동으로 시작이 필요하며 다음 부팅시부터는 자동으로 시작됩니다 :




launchctl load -w ~ / 라이브러리 / LaunchAgents / homebrew.mxcl.php70.plist


launchctl load -w ~ / 라이브러리 / LaunchAgents / homebrew.mxcl.php56.plist



다음으로 Nginx 설정에서 두 개의 가상 호스트를 생성하고 서로 다른 포트로 구성하려고합니다. 예를 들어 eZ 플랫폼 설정에서 PHP 5.6에서 7.0으로, 다시 5.6으로 전환하려면 아래의 두 명령줄만 각각 주석처리하거나 주석을 풀어주면 됩니다:




# PHP 7.0


fastcgi_pass 127.0.0.1:9000;


 


# PHP 5.6


# fastcgi_pass 127.0.0.1:9056;


 



다 됐네요. 이제 여러분은 OS X을 사용할 때 가상머신을 굳이 설치하거나 할 부담 없이 다른 PHP 버전 사이를 쉽게 전환할 수 있습니다..

본 게시글은 작성자에 의해 2017-03-13 12:51:37에 최종 수정되었습니다. (3회)


추천 3

다른 의견 0

다른의견 0 추천 0 니얼굴맛
2017-03-13

다른의견 0 추천 0 유민짱
2017-03-14
  • 욕설, 상처를 줄 수 있는 댓글은 삼가주세요.
짤방 사진  익명요구    
△ 이전글▽ 다음글 -목록보기